Blackboard (All Users) - Supported Browsers, Plugins, and Operating Systems

This document links to a page that can check your browser version, plugins, and operating system to verify compatibility with Blackboard.


This page will automatically detect your browser version and various plugins. A red "X" will indicate if something is needs to be updated in order to use Blackboard with full functionality. Note that some browsers are not supported for use with Blackboard. Students and faculty should use an alternative if their preferred browser is listed as unsupported.

Note: If you passed all the checks, you should be able to use all of the main features of Blackboard Learn. There still may be some issues, for example, downloading a .zip file in Safari. If a browser does not display the content as expected, try a different browsers. ITS recommends Firefox and Chrome as the two most reliable browsers for Blackboard.




Keywords:blackboard, black board, bb, browser*, plugin*, operating system*, supported browser*, compatible   Doc ID:57059
Owner:Center I.Group:Southern Illinois University Edwardsville
Created:2015-10-07 08:58 CDTUpdated:2022-06-30 09:18 CDT
Sites:Southern Illinois University Edwardsville
Feedback:  0   0