QuickTime: How to Edit Video Files

QuickTime Player offers several options for editing your movie, including trim, split, cut/copy/paste/delete, and flip/rotate.

If you don't already have QuickTime installed on your machine, download it using one of the links below:

After downloading, run the file to install the program.

Open QuickTime and click File > Open File...

Browse your computer to find the video file you wish to edit and click Open.

Trim

Use the trim function to remove unwanted parts of your movie.

  1. Choose Edit > Trim. The yellow trimming bar appears, with handles on each end.
  2. Drag the handles to select the part to keep. You can also take these actions:
    • Click the Play button to play back the part selected.
    • Move quickly through the part selected by swiping with two fingers on your trackpad, scrolling with your mouse, or dragging within the trimming bar. 
    • Choose View > Show Audio Track to identify quiet sections of the movie. 
  3. Click Trim. All video and audio outside the trimming bar is removed. To undo the trim, choose Edit > Undo Trim.

Split

Use the split function to split your movie into multiple sections that can be manipulated further.

  1. Go to the point in the timeline where you want to make the split, then choose Edit > Split Clip.
  2. From here you can take several actions:
    • Drag a clip before or after another clip.
    • Move through a clip by swiping with two fingers on your trackpad or scrolling with your mouse. At any point in the timeline, you can choose Edit > Split Clip to split the selected clip.
    • Choose View > Trim to trim the selected clip.
    • Choose View > Show Audio Track to identify quiet sections of the clip. 
    • Select a clip and choose other editing commands from the Edit menu, such as Cut, Copy, Paste, and Delete.
    • Click the Play button to play back all clips. 
  3. Click Done. To see your clips again, choose View > Show Clips. To undo your splits, choose Edit > Undo Split Clip.

Cut, Copy, Paste, Delete

Use the Cut, Copy, Paste, and Delete commands from the Edit menu when you're editing split clips. If you're pasting a clip into another movie, you don't have to be editing clips in that movie: just go to any point in the timeline of the other movie, then paste the clip. 

To quickly join movies together end to end, open the first movie, choose Edit > Add Clip to End, then select the other movie from the file dialog.

Flip, rotate

Use the flip and rotate commands from the Edit menu when you're viewing a movie or editing split clips. These commands flip or rotate the entire movie or clip.

Please note:  The ITS Help Desk does not support QuickTime.  If you are having trouble or need more help, please contact QuickTime:  https://support.apple.com/




Keywords:quicktime, edit, editing, video files, file, .mp4, cut, paste, delete, chop, clip, rotate, trim, unwanted, section, multiple, clip.   Doc ID:72680
Owner:Niki G.Group:Southern Illinois University Edwardsville
Created:2017-04-18 11:40 CDTUpdated:2017-04-18 11:40 CDT
Sites:Southern Illinois University Edwardsville
Feedback:  0   0